<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>
<body dir="auto">
<div></div>
<div>Strike that... this is UNIX.   Please forgive my offensive post.   I should have said when count overflows it attempts to clobber the structure and the kernel gets mad and kills the process.   Please forgive my transgression.  </div>
<div><br>
On Dec 21, 2017, at 8:51 PM, William Corcoran <<a href="mailto:wlc@jctaylor.com">wlc@jctaylor.com</a>> wrote:<br>
<br>
</div>
<blockquote type="cite">
<div><span>Okay, I think I am on to something… </span><br>
<span></span><br>
<span>Whenever tar or cpio dumps core, it is always when 32769 bytes have been written to stdout.  </span><br>
<span>I looked at fprintf and there is a register int called “count.” </span><br>
<span></span><br>
<span>It looks like when it overflows its clobbering a structure and then the kernel gets mad and kills the process.  </span><br>
<span></span><br>
<span>Is it possible this is a latent defect in SVR1 or is there something going on with SIMH?  </span><br>
<span></span><br>
<span>I can’t believe this is a latent defect.  </span><br>
<span></span><br>
<span>Thank you so much for all of your help TEAM TUHS!  </span><br>
<span></span><br>
<span>Much thanks to Clem’s help! </span><br>
<span></span><br>
<span>Bill Corcoran  </span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span>On Dec 21, 2017, at 7:34 PM, William Corcoran <<a href="mailto:wlc@jctaylor.com">wlc@jctaylor.com</a>> wrote:</span><br>
<span></span><br>
<span>Hello Clem,  </span><br>
<span></span><br>
<span>Well, I have some interesting results.  </span><br>
<span></span><br>
<span>First, your comments about fprintf made me think about turning off the output.   So:
</span><br>
<span></span><br>
<span>cd /</span><br>
<span>find . -print | cpio -ocB > /dev/null  </span><br>
<span></span><br>
<span>Works perfectly, the return code is a nice clean 0—No more core dump!  </span><br>
<span></span><br>
<span>However, when I enable the verbose option to cpio, it dumps core.  </span><br>
<span></span><br>
<span>Next, it dumps core using your example below.  However, if I remove the verbose option, cpio completes without error!!!
</span><br>
<span></span><br>
<span>Next, I got a super weird result when I try to print the error code:  </span><br>
<span></span><br>
<span>find .  -print | cpio -ocvB > /dev/null </span><br>
<span></span><br>
<span>   files are displayed…. </span><br>
<span>   Memory Fault: core dumped   </span><br>
<span></span><br>
<span>echo $?</span><br>
<span></span><br>
<span>1003</span><br>
<span></span><br>
<span>Now, I thought all return values were 8 bit?    What is that all about?  </span><br>
<span></span><br>
<span>I just wanted to pass along the update.  I will see if I can follow the string pointers in fprintf.  </span><br>
<span></span><br>
<span>Truly, </span><br>
<span></span><br>
<span>Bill Corcoran   </span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span>On Dec 21, 2017, at 5:30 PM, Clem Cole <<a href="mailto:clemc@ccc.com">clemc@ccc.com</a>> wrote:</span><br>
<span></span><br>
<span>Bill, in the debugger, for both cpio and tar, follow the string ptrs in fprintf and see if you can figure out where its dying.  Also see what value errno is, hopefully it has not been lost.  Neither program should be using printf except for messages to
 the console, so I'm guessing this is an error message trying to be output from an error the kernel returned.   See if you can find the message from cpio/tar and the error code and that might give you a hint to look in the kernel.</span><br>
<span></span><br>
<span>Could you be running out of open files, maybe.</span><br>
<span></span><br>
<span>Another thing to try, is:  cd /</span><br>
<span>find . -print​ > /tmp/file.lst</span><br>
<span>cpio -ocvB > /dev/null​ < /tmp/file.lst</span><br>
<span></span><br>
<span>See if that changes anything.   It should remove some of pressure on the kernel tables.</span><br>
<span></span><br>
<span>​Clem​</span><br>
<span>​</span><br>
<span>ᐧ</span><br>
<span></span><br>
<span>On Thu, Dec 21, 2017 at 5:12 PM, William Corcoran <<a href="mailto:wlc@jctaylor.com">wlc@jctaylor.com</a>> wrote:</span><br>
<span>Hello Team TUHS:</span><br>
<span></span><br>
<span>I am having a problem with my PDP-11 SVR1 running under a recent SIMH build.  My problem occurs on both MAC OS X and FreeBSD.</span><br>
<span></span><br>
<span>First, I created a six disk (RP06) and eight port TTY (DZ) kernel, with swap placed on drive 1.  The system behaves beautifully as FSCK reports clean.  Eight users can login with no problem.</span><br>
<span></span><br>
<span>Second, I reverted to a pristine PDP-11 SVR1 with one drive (RP06) and no DZ and booted the default kernel (gdtm) and I see the same problem described below.</span><br>
<span></span><br>
<span>Third, when using the tape driver instead of /dev/null i get the same results.</span><br>
<span></span><br>
<span>Next, here is the issue:</span><br>
<span></span><br>
<span>cd /</span><br>
<span>find . -print | cpio -ocvB > /dev/null</span><br>
<span></span><br>
<span>It runs for a short while and then shitz a core:</span><br>
<span>I am using /dev/null to take the tape driver out of the equation.</span><br>
<span></span><br>
<span>Here is the backtrace for cpio:</span><br>
<span></span><br>
<span>$c</span><br>
<span>__strout(053522,043,0,053012)</span><br>
<span>__doprnt(046652,0177606,053012)</span><br>
<span>_fprintf(053012,046652,053522)</span><br>
<span>~main(02,0177636)</span><br>
<span></span><br>
<span></span><br>
<span>Now, interestingly,  I run into a similar issue when using tar:</span><br>
<span></span><br>
<span>cd  /usr</span><br>
<span>tar -cvf /dev/null .</span><br>
<span></span><br>
<span>Again, this will run for a while, then drops a core.  Here is the backtrace for tar:</span><br>
<span></span><br>
<span>$c</span><br>
<span>__strout(043123,02,0,045506)</span><br>
<span>__doprnt(043123,0167472,045506)</span><br>
<span>_fprintf(045506,043123,0170600)</span><br>
<span>~putfile(0170600,0170641)</span><br>
<span>~putfile(0171654,0171704)</span><br>
<span>~putfile(0172730,0172745)</span><br>
<span>~putfile(0174004,0174016)</span><br>
<span>~putfile(0175060,0175066)</span><br>
<span>~putfile(0176134,0176136)</span><br>
<span>~putfile(0177672,0177672)</span><br>
<span>~dorep(0177632)</span><br>
<span>~main(04,0177630)</span><br>
<span></span><br>
<span>This really bugging me since my SVR1 is otherwise working flawlessly.  I was able to remake the entire system and custom kernels that boot with no problem.</span><br>
<span>Also, I configured my main port to run inside the AWS Lightsail and now I have access to SVR1 from anywhere in the world!</span><br>
<span></span><br>
<span>I was also wondering if doing a CPIO or TAR on the entire system was overflowing some link tables and maybe this is expected behavior for the minimal resource of the PDP-11?</span><br>
<span></span><br>
<span>Thank you for any help.</span><br>
<span></span><br>
<span>Would you expect tar or cpio to dump core if you attempted to copy large filesystems  (or the entire system) on a PDP-11?</span><br>
<span>Note: All of my testing has been in single user mode.</span><br>
<span></span><br>
<span></span><br>
<span>Truly,</span><br>
<span></span><br>
<span>Bill Corcoran</span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
<span></span><br>
</div>
</blockquote>
</body>
</html>