[TUHS] Archaic yacc C grammar

Clem Cole clemc at ccc.com
Wed Oct 31 23:49:29 AEST 2018

On Tue, Oct 30, 2018 at 9:46 PM Larry McVoy <lm at mcvoy.com> wrote:

> Instead of
>         p->size
> we have
>         p->st_size
> and I instantly know that p is a struct stat pointer.
Amen Larry.   I understand why people had a desire for different
namespaces, but a single namespace sure made code a lot more readable and
I still use that trick in new code, because I think it just makes it easier
to identify what is going on when I glance at it.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://minnie.tuhs.org/pipermail/tuhs/attachments/20181031/a3f6b5c3/attachment.html>

More information about the TUHS mailing list