[TUHS] New PDF version of Installing and Using Research Unix Version 7 In the SimH PDP-11/45 and 11/70 Emulators

Will Senn will.senn at gmail.com
Sat Oct 14 03:58:52 AEST 2017

Hi Gregg,

In addition to Mint, I just confirmed the instructions work without 
modification on a Raspberry Pi 2 Model B (the $30 dollar pi comes with a 
quad core 900MHz 32 bit ARM processor with 1GB Ram and a slot for my 32 
GB Micro SD for storage). I'm sure the rpi3 works, but faster (quad core 
1GHz, 64 bit ARM, better design...). My system reports:

uname -a
Linux raspberrypi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 
armv7l GNU/Linux

cat /etc/debian_version

Sure, it's slower than my MacBook Pro, but that just makes it seem more 
realistic (pseudo realistic for sure, it's still orders of magnitude 
faster than a real PDP 11).



On 10/12/17 2:11 PM, Gregg Levine wrote:
> Hello!
> I was thinking of Linux, since it and FreeBSD, and even NetBSD, are
> next door neighbors of a sort. But at least it is a start. Thank you!
> -----
> Gregg C Levine gregg.drwho8 at gmail.com
> "This signature fought the Time Wars, time and again."
> On Thu, Oct 12, 2017 at 1:34 PM, Will Senn <will.senn at gmail.com> wrote:
>> Gregg,
>> I'm not sure I understand your question exactly, but as mentioned in the
>> note, I tested the instructions on Mac OS X Mavericks through MacOS High
>> Sierra as well as multiple flavors of FreeBSD 10-11. Your comment sparked my
>> interest in trying it out on Windows (maybe that's the OS non-grata?), so I
>> tested it there as well. Seems to work, although I found the experience
>> distasteful in the extreme . The number of tools missing on that OS are mind
>> boggling... but I did get it working. In full disclosure, I couldn't bring
>> myself to run it on metal. I just ran the Windows  8.1 Enterprise
>> environment in a VM running on Linux Mint 18.2 (a debian/ubuntu variant).
>> Just so you know, I have to have a *nix like set of tools on any OS I use,
>> these days, or I feel like my left arm is missing, so the minimal workable
>> set for me in this case was Git with unix tools (a version on MinGW, I
>> think). I used to use Cygwin, but it's so bloated it's sickening and the
>> installer is unfriendly to say the least (I would be satisfied with a button
>> that said "reasonable set of unix tools", but the minimal selection is
>> minimalist, not reasonable). Anyhow, Git with unix tools will get you a bash
>> shell that has an almost reasonable set of tools. Enough the do the work
>> required for this note anyway. SimH has binaries for windows to download. I
>> picked the one that was created 29 days ago, unzipped it, put it on the path
>> and it just worked. Quite a few steps in the prep required minor tweakage
>> (no vi, no emacs - see what I mean about minimal not being reasonable, but
>> notepad++ worked ok; no gunzip, but gzip -d < zipfile > unzipped worked,
>> perl script didn't seem to work right, not sure what that's about - may look
>> into it later, since I wrote it, but in the meantime I just downloaded the
>> tap file from the archive and it worked fine)...
>> Bottom line for windows, download the tap file from the archive, create two
>> ini files, one for first boot, the other for normal boot and the rest of the
>> instructions work verbatim.
>> I haven't bothered with linux, just cuz I somehow didn't, but I gather it
>> will probably work about as well as on the BSD's.
>> Is that what you were asking, or something more subtle?
>> Regards,
>> Will
>> On 10/12/17 12:32 AM, Gregg Levine wrote:
>>> Hello!
>>> (If this is seen twice, then that's because Google complained that the
>>> mangle list wasn't accepting messages.)
>>> Will, has this been idea been tested on any of the platforms that the
>>> emulator runs on? (Not going to mention one in particular by name
>>> since it's sore spot around here.)
>>> -----
>>> Gregg C Levine gregg.drwho8 at gmail.com
>>> "This signature fought the Time Wars, time and again."
>>> On Thu, Oct 12, 2017 at 1:08 AM, Will Senn <will.senn at gmail.com> wrote:
>>>> Hi all,
>>>> I just finished creating an updated PDF version of a blog post I did a
>>>> couple of years back, describing how to install and use Unix v7 in SimH.
>>>> It's updated for 2017 and MacOS High Sierra 10.13. I started the update
>>>> because I was wanting to do some research in v7 and thought it would be
>>>> good
>>>> to have a current set of instructions but really because I was interested
>>>> in
>>>> learning a bit about LaTeX and creating prettier, more useful documents.
>>>> The
>>>> notes still work fine as originally written, but I organized things a
>>>> little
>>>> differently and tweaked some of the language. I thought somebody else
>>>> might
>>>> like having a PDF version around so I uploaded the result, call it
>>>> revision
>>>> 1.1, and made it publicly accessible (the blog still needs updating,
>>>> somebody oughta do something about link impermanence, but that's all for
>>>> another day). Feel free to comment or complain. I added a section in
>>>> honor
>>>> of dmr at one commenter's suggestion. Here's the link:
>>>> https://drive.google.com/open?id=0B1_Jn6Hlzym-Zmx1TjR3TENDQTA
>>>> Later,
>>>> Will
>>>> --
>>>> GPG Fingerprint: 68F4 B3BD 1730 555A 4462  7D45 3EAA 5B6D A982 BAAF
>> --
>> GPG Fingerprint: 68F4 B3BD 1730 555A 4462  7D45 3EAA 5B6D A982 BAAF

GPG Fingerprint: 68F4 B3BD 1730 555A 4462  7D45 3EAA 5B6D A982 BAAF

More information about the TUHS mailing list