[TUHS] shell PS1/PS2 which survive cut-paste

Dave Horsfall dave at horsfall.org
Fri Dec 8 10:31:37 AEST 2017

On Thu, 7 Dec 2017, Clem Cole wrote:

> > Never got to use the V7 shell; we were stuck with 11/40s[*] 
> Dave I don't understand this statement.  We ran Seventh Edition on 11/40
> class processors more than anything else.  The issue was lack of separate
> I/D space and the kernel got large so you ran out of physical memory.   The
> later was solved with things like the Able ENABLE, which I admit I put one
> couple of 11/34 and our 11/60 (which are 11/40 class).  But V7 ran fine on
> it.

I tried, but no way it would work; the only non-DEC gear we ended up with 
was extra memory (nothing special, but of course not covered by Field 
Circus) and an Ampex[*] RP-03 clone (I think).  For all intents and 
porpoises it was a maxed-out 11/40 (then the /60 later on).

As I mentioned before, the AUSAM buffer scheme certainly helped, and we 
kissed goodbye to deadlocks; we even modified character devices (LP. XY, 
LV etc) to use the buffer pool instead of the character queues, and they 
went damned fast.

I should mention that the /40s were originally specced to run RSX-11D 
(yuck), and when the ACM article came out the rest was history...

My spell checker suggested "Tampax" for "Ampex"...

Dave Horsfall DTM (VK2KFU)  "Those who don't understand security will suffer."

More information about the TUHS mailing list