[TUHS] looking for a quote

Ralph Corderoy ralph at inputplus.co.uk
Thu Dec 7 21:50:24 AEST 2017

Hi Larry,

> I *much* prefer sbuf.st_size than whatever.size, the former is
> instantly a stat structure, the later is a "whatever".

It's awful.  :-)
st.st_size `stutters' and that jars when reading in my head.
If st.size isn't clear from context, then stbuf.size probably is.
Ditto ar_hdr->uid versus hdr->ar_uid.

There's a hierarchy to walking the data structure, and that should be
represented in the identifiers.  So big.little, not b.bg_little.

Cheers, Ralph.

More information about the TUHS mailing list