[TUHS] boot block in v7 bootable on rp06 in simh

Will Senn will.senn at gmail.com
Sun Dec 6 04:39:36 AEST 2015

Problem solved - see below.

On 12/5/15 12:01 PM, Will Senn wrote:
> On 12/5/15 11:53 AM, Hellwig Geisse wrote:
>> Will,
>> One note of caution: I did not try to build the whole thing
>> on a modern 64-bit system; it may well refuse to run. I will
>> try to bring it up on my 64-bit Linux box and then report
>> back here, if you are interested.
>> Hellwig
> Hellwig,
> Much thanks for the explanation and link. I will try your instructions 
> and see if they still work. Your notes are exceptionally clear, I 
> expect if I follow them things, will work as expected. I'll let you know.
> Thanks,
> Will
Well, you were right, sim didn't want to build 64 bit. However, I 
already had a working sim, so I simply used the existing pdp11 binary 
and your instructions. They worked!

In the process, I figured out that the original approach that I used 
worked as well. The issue wasn't with the RP disk, it was with the 
singular lack of a Boot prompt '@'. There isn't one. After the simulator 
prints 'Disabling XQ', the boot loader is just sitting there waiting for 
the user to type 'boot', at which point the loader will print 'Boot' and 
the ':' prompt will appear, allowing the kernel to be specified:

pdp11 tboot.ini
PDP-11 simulator V4.0-0 Beta        git commit id: 0f43551d
Disabling XQ
: hp(0,0)unix
mem = 2020544

Thanks Hellwig and thanks Cole!



More information about the TUHS mailing list