[TUHS] Codata restoration - day 1

Dave Horsfall dave at horsfall.org
Sat Oct 11 05:55:10 AEST 2014

On Fri, 10 Oct 2014, Engel, Michael wrote:

> > The P2 bus is designated as "private" i.e. do whatever you want with 
> > it with your proprietary hardware.  I don't think the "standard" CPU 
> > board even looks at it.
> That's what I also thought. Do you know if there were systems which used 
> P2 to connect to memory boards?

I think (and this is going back to the early 80s) that some WICAT models 
did.  I've used the 150, 160, and 200, but never saw a 220.  The smaller 
models were Multibus, and the 200 on had something loosely based on it and 
was unofficially referred to as the Pussy-bus.  The P2 bus on those small 
ones was used for something that I've long since forgotten; there was a 
project in the Lionel Singer Group (Aussie agent for WICAT) to use 
standard Multibus cards in them until we discovered upon reading the 
circuits (we had circuit diagrams in those days!) that WICAT had hijacked 
the P2 bus, possibly for extended memory, possibly for its weird ICI board 
(8-port serial board + disk, as I vaguely recall), possibly something 

I was glad to see the end of the WICATs, because their attempt at System 
III was woeful; I had to do pre-sales demos, *knowing* that the damned 
thing would crash on me, and got very good at excuses.  "Sorry guys, we've 
been having a bit of trouble with this new controller, but we're told 
it'll be fixed Real Soon Now(tm)" when I knew that it was the poxy OS at 
fault.  How do you explain to the customer that the OS itself is 
fundamentally rat-shit?

I am desperately trying to forget the exact details, but it involved 
someone telling Lionel Singer himself that his half-arsed idea was just 

> [...]
> >> The serial cable is working, we tried all sorts of handshake 
> >> configurations. If we get any characters back (the system is running 
> >> at 9600 baud, I tried all combinations of 7/8 bit, 
> >> none/even/odd/mark/space parity and 1/2 stop bits), these are garbled 
> >> and contain mostly "1" bits (0xfc, 0xfe, 0xff or similar).
> > 
> > Have you tried speeds other than 9600?  They look to me like framing 
> > errors.
> The terminal emulator (screen and minicom behave identically) receives 
> the output from the console perfectly - otherwise, I would have also 
> suspected an incorrect baudrate. And different baudrates for RX and TX 
> would be highly unusual (I have only seen these in German BTX dialup 
> systems in the 1980s, which used 1200/75 baud modems).

1200/75?  That was popular in Australia, on a scheme called Viatel, which 
thankfully died off when ISPs began to rise up (until then it was either 
FidoNet or the Phone Company's Viatel) and implement 1200/1200.

> Luckily, the driver chip for the UART RX line is an AM26LS32. While this 
> chip is no longer available, I can get an AM26LS32A here at Farnell 
> (which is just around the corner from my house :-)). Does anyone know 
> the difference between the 26LS32 and the 26LS32A? I only found a page 
> at TI that didn't list specific differences...

Offhand no, but Farknell (as they're known in Australia - say it out loud) 
ought to know, as they're pretty clued up.

-- Dave

More information about the TUHS mailing list