[TUHS] Codata restoration - day 1

Engel, Michael M.Engel at leedsbeckett.ac.uk
Sat Oct 11 03:26:58 AEST 2014


after carefully examining the power supply and checking the generated
voltages, we were convinced that this wouldn't kill our Multibus boards.
Maybe some of you are interested in our progress, so I though I would
send you an update.

After reconnecting the Multibus backplane, we started the system with
only a CPU board and a memory board. On one of our CPU boards
the smaller (P2) Multibus connector is masked with tape, I'll have to dig 
deeper to find out what is deactivated by this…

One of our two CPU boards is currently non functional (the one without
the masking take, this doesn't say a thing on the console UART, will bring 
in the scope in Monday to check for details). The other one brings up the
monitor startup message and prompt on a connected serial terminal 
(emulator) - however, we are unable to get any characters echoed back.
The serial cable is working, we tried all sorts of handshake configurations.
If we get any characters back (the system is running at 9600 baud, I tried
all combinations of 7/8 bit, none/even/odd/mark/space parity and 1/2 stop
bits), these are garbled and contain mostly "1" bits (0xfc, 0xfe, 0xff or 

The UART itself seems to work (exchanged it with the one from the non
working board - same result), so now I suspect the AM26LS32 RS423
driver to be the culprit.

I uploaded some pictures to 
- there you can see that this machine is far from being in any sort of 
original condition. Nevertheless, it's great to see it come alive again!

Btw., current versions of MAME/MESS include a rudimentary Codata
simulator. This doesn't do very much so far, but it can successfully run 
the firmware ROM code (picture also uploaded to photobucket).

Best wishes,

More information about the TUHS mailing list