In the bootable images archive, there's the "Unknown V6" RL02 image. I've tried that on SimH configured as an 11/23+ with 256kB of RAM and it seems to work fine. It seems to be somewhat tweaked, as the shell accepts "cd" instead of "chdir" and I know the C compiler is happy with either "+=" or "=+". It seems to be reasonably complete (at least binaries I mean). I can't recall if the source files are there or not.

I guess at least if I use LSX and V6 then they both are V6 based, which might minimize pain. I'd imagine stuff I write for the '23 would also then compile on the '03.

I'll have some fun eventually on these machines with my home automation system. I've picked-up an RS-232 -> WiFi module on TaoBao (China's answer to eBay) and I'll implement a super-lightweight MQTT system to drive some stuff at home. (Think custom Christmas lights.) I would assume that Ethernet boards are available, but not supported on V6.

Anyone else have an LSI machine at home? I'd be interested to know some fun stuff to do with it.


Paul Riley

On Sat, 19 Sep 2020 at 23:28, Noel Chiappa <> wrote:
    > From: Paul Riley

    > Is LSX the only option on the 11/03, or could I run V6 or Mini-Unix with
    > more RAM?

All PDP-11 Unix versions from V4 on require the MMU, so the -11/03 is out for
them. We don't have the code for V2-V4, though. So V1 (mostly all assembler,
no C :-), LSW and Mini-Unix are the only options for it.

V6 can be run on an -11/23 (I've done it), but not straight out of the box;
it requires a few minor tweaks first: