I can try to pull some info from long ago paged out memory.  I havent had to run UUCP since the late 1990s.   By the Stellar time, we were on the Internet and UUCP had pretty much become unnecessary for most folks.

On Mon, Jun 29, 2020 at 12:42 PM Grant Taylor via COFF <coff@minnie.tuhs.org> wrote:
Do you by chance recall what UUCP software was being used?  Was it by
chance Taylor UUCP?  Or was it some other UUCP package in OpenBSD?
BSD was originally based on V7 UUCP with some fixes.   Eventually Honey-Dan-Ber came out in the very early 1980s and most of the commercial UNIX's licensed/relicensed/redistributed it. V7 and HDB were the versions that built the USENET.

As Larry said, V7 definition needed a baby sister, HDB got to the point that it pretty much worked without having to watch it too much.  The biggest issue was that disks were much smaller in those days and overflow of the spool area was not uncommon.

Taylor UUCP was much later and was a mostly FOSS implementation of H-D-B.   I never ran it.

The original ORA UUCP manual (that Tim actually wrote the first draft) was always the definitive guide to running.

> Are you trying to configure dial-up UUCP or UUCP-over-IP with uucpd?

I'm trying to configure UUCP-over-SSH.  It's probably closer to
UUCP-over-modem than it is UUCP-over-IP (TCP).  The ""modem pipe is the
ssh command which remotely connects to the destination host (using keys
to authenticate) and launching uucico through the SSH connection STDIO.
What protocol is it running?   Chesson's 'g' protocol (which was the default).  How is the chatting being done?   That's were most issues tended occur.   Remember the expect(1) program was created by the folks at NIST modelling after Ber's version of chat for H-D-B.  My guess is that something in macOS's way of running login might be doing something unexpected and confusing uucico.

I might suggest try debugging with two computers talking over a serial link.   Just add a USB to serial to each of your systems.   Set up a login one link and get the other side to open the other.  The hard part is Apple dorked the login scheme from traditional UNIX/so you'll need to make sure it does not try to do something too funny.  Basically you need to be able to run cu (or the equiv) from one system to the other and login in a normal user.   If you can do that and nothing is screwy, then try to login at user uucp and see if uucico is properly forked.

Maybe the answer is pull an old getty/login pair off BSD and set up a daemon to fake it so that Apple login stuff is not in the way.  But the trick is that once you make that work, you can then set up uucp the way it was expected to run.

FWIW:  ssh did not exist when UUCP transitioned to running on IP - so I suspect it was never really, debugged worked out.   There was no need.   Just so you know, a couple of UUCP of ethernet were done.  I wrote the first one (the e protocol) for the Masscomp systems, which I gave back to Sam and Keith was in the BSD release.   IIRC there were a couple of others that different people did also.