[Unix-jun72] Readme written: needs checking

Warren Toomey wkt at tuhs.org
Wed May 7 05:28:42 EDT 2008


On Wed, May 07, 2008 at 09:40:43AM +0100, P.A.Osborne wrote:
> On OS X 10.5.3
> simh builds fine however:
> building apout fails (everything else in tools compiles) with:

Thanks Paul, I'll try to fix it tomorrow. Is there a compiler defined
preprocessor symbol that I can add which covers OSX. For example:

#if !defined(__FreeBSD__) && !defined(__NetBSD__) && \
    !defined(__OpenBSD__) && !defined(__linux__)
# define NEED_INT_N
#endif

Is there __OSX__ or similar? If there is, simply add

	&& !defined(__OSX__)

to that second line, which is around line 71 in tools/apout/defines.h.

Thanks,
	Warren



More information about the Unix-jun72 mailing list