[TUHS] SCO OpenDesktop 386 2.0.0

Josh Good pepe at naleco.com
Thu Mar 2 08:45:31 AEST 2017


On 2017 Feb 27, 14:59, Arthur Krewat wrote:
> I've been trying this myself today, both on ESXi 6.0U2, and I went and 
> installed ESXi 5.0 as a guest under 6.0U2 :)
> 
> I notice that when I put the CD as IDE 1:0 (bus 1, master) it doesn't 
> find it. When I put it as 0:0 (bus 0, master), it hangs loading the IDE 
> driver.
> 
> I suspect it doesn't know about bus 1, so it doesn't hang but also 
> doesn't find it, and there's something wrong with either VMware's 
> implementation of IDE, or SCO's handling of it - or both. I've read 
> where lots of devices in VMware are just to "perfect" for some device 
> drivers to deal with. One glaring example was you couldn't use the LSI 
> SAS driver with Solaris 11. It would either hang or panic, I forget 
> which. Switch to LSI Parallel SCSI, and it was fine.
> 
> Anyway, I suspect that there's something in the IDE driver that's 
> ignoring bus1, and hanging with VMware's implementation of it.
> 
> I'm going to try installing ESXi 4.0 and see what happens.
> 
> On another note, it's possible I just need to install the hard drive as 
> IDE from the get-go, have the CDROM as slave on bus 0 and see what happens.
> 
> Any pointers?
> 
> thanks!
> art k.
> 
> 
> On 2/27/2017 12:12 PM, Cory Smelosky wrote:
> >Corey Lindsly wrote:
> >>>Count me in. I put my hand up for a copy of SCO when they were 
> >>>offering free
> >>>samplers in the early 2000s, but never heard back from them.
> >>>
> >>>I wanted to compare it with Linux ...
> >>>
> >>>Thanks
> >>>
> >>>Wesley Parish
> >>
> >>For anyone interested, the SCO 2.1 images are available for download 
> >>here:
> >>
> >>http://lod.com/sco
> >>
> >>A few things:
> >>
> >>1. I am having some difficulty getting it to install in VMWare ESXi 
> >>5. The
> >>floppy image boots, and I get some way into the install process, but SCO
> >>install does not see the virtual CD-ROM drive. Thus, I'm presented with
> >>network install options only. At this point, there are a few options:
> >>
> >>(a) Track down the driver and/or VMWare settings to fix the CD-ROM
> >>visibility, and proceed with the install.
> >>
> >>(b) Set up a SCO network install server, and proceed.
> >>
> >>(c) Try the install on legacy physical hardware instead.

I got it to install successfully, in VMware Server 1.0.2.

The solution is to boot normally with the "id.dd" floppy image provided
by Corey Lindsly, with the ISO image also provided by Corey configured
as IDE 0:1 (first channel, slave), and with a virtual IDE disk (I'm
using 8 GB of size) as 0:0 (first channel, master).

This setup leads to the already known IDE driver hanging. It's a
problem with the IDE driver provided by SCO with UnixWare 2.1. So,
when the install process asks whether you want to use a "HBA diskette",
load into your PC emulator's virtual floppy drive the updated "HBA
diskette" image provided by SCO for UnixWare 2.1.3, which is here:
ftp://ftp.sco.com/pub/UW21/upd213/hba213.img

This will stop the UnixWare 2.1 IDE driver from hanging, and the
install process will proceed successfully to completion.

It should work equally well in VirtualBox.

Regards,

-- 
Josh Good



More information about the TUHS mailing list