[TUHS] SCO OpenDesktop 386 2.0.0

Cory Smelosky b4 at gewt.net
Tue Feb 28 06:08:55 AEST 2017


Cory Smelosky wrote:
> Arthur Krewat wrote:
>> I've been trying this myself today, both on ESXi 6.0U2, and I went and
>> installed ESXi 5.0 as a guest under 6.0U2 :)
>>
>> I notice that when I put the CD as IDE 1:0 (bus 1, master) it doesn't
>> find it. When I put it as 0:0 (bus 0, master), it hangs loading the IDE
>> driver.
>>
>> I suspect it doesn't know about bus 1, so it doesn't hang but also
>> doesn't find it, and there's something wrong with either VMware's
>> implementation of IDE, or SCO's handling of it - or both. I've read
>> where lots of devices in VMware are just to "perfect" for some device
>> drivers to deal with. One glaring example was you couldn't use the LSI
>> SAS driver with Solaris 11. It would either hang or panic, I forget
>> which. Switch to LSI Parallel SCSI, and it was fine.
>>
>> Anyway, I suspect that there's something in the IDE driver that's
>> ignoring bus1, and hanging with VMware's implementation of it.
>>
>> I'm going to try installing ESXi 4.0 and see what happens.
>>
>> On another note, it's possible I just need to install the hard drive as
>> IDE from the get-go, have the CDROM as slave on bus 0 and see what
>> happens.
>>
>> Any pointers?
>>
>> thanks!
>> art k.
>>
>>
>
> bochs' IDE implementation results in it crashing and in qemu it panic()s
> before loading the installer.

I believe VirtualBox crashed at about the same point as qemu.


More information about the TUHS mailing list